Dell Mini 9 OS X Discussion Discussion for installing and setting up Mac OS X on the Dell Mini and Vostro A90

Thread Tools Display Modes
  (#1) Old
blehmann blehmann is offline
Posts: 38
Join Date: May 2009
Default help with partially resuscitated mini 9 with flickering screen - 01-26-2010, 04:40 AM

I had two problems with my daughter's mini 9 six weeks ago. The screen 1/2 inch wide three inch long blotchy green and black something in the upper left hand corner of the screen. The mini 9 would boot up to the pinwheel and then would die. See the two links below if you are interested. I was thinking about replacing it today and decided to see if there were no clues on the forum and here is what happened.

I ended up trying a lot of unix -blank commands. -v followed by exit shut the machine down as did -s followed by exit. I do not understand why but -s followed by /sbin/mount/ -fy (I think) followed by exit allowed me to boot up! Go figure.

I have not shut the machine down since, although I did let it lock the screen and I was able to unlock. The green and black blotch is still there and, after about an hour, the screen developed a flicker that has not gone away. The flicker is a ghost of the actual screen that is about 2 inches below the top of the screen.

So what do I do? Will replacing the screen likely fix this problem or might it be a video card as well? I am willing to try to fix it but I would like to have an idea if I must do more than a screen replacement. Any thoughts?

One more thing. If I let the mini 9 go to sleep or even shutdown, should I expect the machine to wake up or reboot normally?

Another one more thing. I cannot turn airport on. Am I correct in thinking I should reinstall the mac os after the hardware problem is fixed?
Reply With Quote
  (#2) Old
grassle grassle is offline
Senior Member
Posts: 373
Join Date: May 2009
Default 01-26-2010, 01:30 PM

The flicker and blotch may point to a broken lead (or more) in the display cable if they react to display movement.

The bootup problem: does it appear when booting with an external display connected? And (you have to use your screwdriver) the internal display disconnected?
Reply With Quote
  (#3) Old
blehmann blehmann is offline
Posts: 38
Join Date: May 2009
Default 01-26-2010, 10:20 PM

I got the same idea and booted up with an external monitor.
the external monitor works fine but I still have to boot by hitting -s followed by /sbin/mount/ -ew / (I think) and then it will boot up. My presumption is that the mac os is broken. Am I right?
Reply With Quote

« Trouble installing on Mini 9 | Mini 9 Hackintosh has slowed down noticeably »
Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Copyright © 2008-2016