Dell Mini 9 OS X Discussion Discussion for installing and setting up Mac OS X on the Dell Mini and Vostro A90

Thread Tools Display Modes
  (#1) Old
AussieBattler AussieBattler is offline
Junior Member
Posts: 1
Join Date: Sep 2009
Default Delete Key behaving strangely - 09-05-2009, 04:38 PM

Hi. I have completed the instructions to covert my Dell Mini 9 to using OS X 10.7 and everything works except the three keys on the top right hand corner (hyphen/underscore, plus/equals, backspace). Whenever I use these keys they work but they add a hypen (for example, if I click the backspace it completes the backspace but then adds a hyphen).

Occasionally, if I click on one of these keys then it adds multiple hyphens (as if the hyphen key was stuck). Other times the keys work as expected (but not very often).

I have tried to find a solution but can't locate one. Has anybody experienced this problem before? Suggestions? Ideas?

Reply With Quote
  (#2) Old
jetkins jetkins is offline
Senior Member
jetkins's Avatar
Posts: 183
Join Date: Jul 2009
Location: Austin, TX
Default 09-05-2009, 09:05 PM

Sounds like a hardware problem to me, mate. I'd try booting another OS - perhaps a Linux live CD or even a DOS floppy - and verify whether it does the same thing; I'll bet it does. Might be worth giving that area of the keyboard a good blast with a can of compressed air before resorting toa service call.

White Mini 9 | 2GB Transcend RAM | 16GB RunCore | 16GB Patriot Class 6 SDHC | Internal BT | 1505 802.11n | BIOS A05 | OS X 10.5.8
Thinking of trying Dropbox? Use this referal link and we'll both get an extra 250MB of storage.
Reply With Quote
  (#3) Old
SBK SBK is offline
SBK's Avatar
Posts: 39
Join Date: Jan 2009
Location: Michigan, USA
Default 09-06-2009, 03:58 PM

Aussie, as jetkins is suggesting - might be a H/W problem? Did you have the keyboard out for any kind of hardware upgrade where it may have gotten tweaked on dis-or-reassembly?

There are disassembly instructions floating around here on the forums, might be worth taking apart and checking for issues with a careful reassemble.

2GB RAM 32GB RunCore OS X 10.5.8 NetbookInstaller 0.8.2 Final Internal Bluetooth Webcam
Mini10v 2GB RAM 160GB HDD OS X 10.6.3
NetbookInstaller 0.8.4 RC1 Internal Bluetooth Webcam
Reply With Quote
  (#4) Old
bsoplinger1 bsoplinger1 is offline
Expert Member
Posts: 692
Join Date: Mar 2009
Default 09-06-2009, 06:25 PM

If those keys are indeed the 3 right most upper keys, then you have an international and not US keyboard. Check out the replacement keyboard over in the mini9 hardware forum. I think it lists the magic keyboard combo to press at boot time to tell the mini which keyboard you have. Even if you just have the regular keyboard there is a key combo for that and perhaps that will help you with your keyboard problem.

Mini1: Vostro A90, Black, 2G, 1.3 Webcam, Bluetooth, 64G SuperTalent, OS X 10.6.4
Mini2: Mini9, Black, 2G, 0.3 Webcam, Bluetooth, 32G RunCore, OS X/Win 7, internal PCI-e SHDC Reader
Mini3: Mini10v. Black, 2G, Webcam, 640G HD, OS X 10.5.8/Win 7/Ubuntu [Hibernate w/NBI 0.8.3 RC4]
Dropbox Referral
Reply With Quote

« Early reserve battery warning then low performance for 1h... | Netbook Installer broke USB Audio Devices..? »
Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Copyright © 2008-2016