Dell Mini 9 Hardware Issues / Problems Inform everyone on any issues or problems with your Dell Mini 9 hardware.

Reply
 
Thread Tools Display Modes
  (#1) Old
DjFIL DjFIL is offline
Junior Member
 
Posts: 7
Join Date: Oct 2008
Default MERGED AC power disables when battery hits 100% charge. - 10-31-2008, 05:39 AM

ALL DELL MINI 9 BATTERY CHARGING ISSUE THREADS HAVE BEEN
MERGED HERE


If your Mini 9 battery stops charging and doesn't run off the AC once it has reached full charge, you need to get your motherboard replaced.

There have been many theories that it's the BIOS, AC adaptor or the battery, but this is never the case. Your best bet is to get onto Dell Support and explain to them the problem and that you've tested it with various batteries and chargers (lie if you have to!) and that montherboard needs replacing. You'll need to do this within your warranty, otherwise this may cost you.

Take it from a man whose experienced this himself! Just get onto Dell Support right away!

~Dunhamzzz

Thread:

I'm trying to figure out what has started to cause this issue for me, if it's software or if it's hardware. This only reciently started happening. When my Mini 9 is running on AC Power, once the battery charge reaches 100%, the system automatically changes over to battery power. If I unplug the AC cord and plug it back it, it won't go back to AC Power... even if i wait 5-10 minutes and then plug it back in (so it loses a bit of the charge), it still won't go back to AC Power. Only once I reboot the computer with the AC cord plugged in, then it will go to AC power. Also if it has shut down with the AC plug attached, the power indicator lite comes back on (once shut down) as if it's charging via AC power again. This first under Dell's Ubuntu Mini OS.

I originaly had XP installed from the factory, I've upgraded the BIOS to A01 from Dell's support pages. I never experianced this issue in XP. I then installed OSX86... I only had it on for a short time (because of the sleep resume & built-in sd card reader issues), but I don't recall the issue ever occuring under OS X. I then found the ISO for Dell's Ubuntu Mini OS (netbook remix)... now I re-installed this OS a few times, as I kept trying to tweek the top panel and few other compoents (items that I took from canonical's offical netbook remix repositories), and I kept breaking it. I never noticed it in the earlier installs... but on the latest install (once i had everything configured to my liking) I now started to have the issue I've explained. I left it alone for a while as I was trying to find fixes for this issue. I noticed that an update had come out from Dell few days ago, I installed that, but it hasn't fixed my issue. Today with the release of Ubuntu 8.10, I downloaded that ISO and tried to install it. It installed with no issues (never got around to test the audio)... but I'm still having the same battery issue.

Tonight I'm going to first try and reinstall the Dell Mini OS and all it's new updates to see if it resolves the issue. If not, I'm going to try and go back to the original XP discs that were supplied with my Dell Mini 9. I really hope this is just a software issue. Has anyone else experianced this issue? Is there anyway to flash my BIOS back to A00?

Thanks.
Reply With Quote
  (#2) Old
DjFIL DjFIL is offline
Junior Member
 
Posts: 7
Join Date: Oct 2008
Default Re: AC power disables when battery hits 100% charge. - 10-31-2008, 07:59 PM

anyone else experiencing this? some Dell TSR is trying to pass this off as how the hardware has been designed... which is total BS. why would you waste battery charge cycles when it's plugged in to AC power.

EDIT: i'm still on phone with them... looks like this guy, after consulting who ever he consults, finally realizes this isn't normal... i'm off to RMA support for repair/replacement.
Reply With Quote
  (#3) Old
gunn gunn is offline
Member
 
Posts: 33
Join Date: Nov 2008
Default Re: AC power disables when battery hits 100% charge. - 11-02-2008, 12:13 PM

Just ran into the same problem yesterday.

My Mini is:
16G version
A genuine Ubuntu 8.04 (as opposed to the Dell Remix)
Bios: A00

So this annoying bug (?hopefully) happened a few times, but not every time. Waited for the battery to run under 50%, plugged in the cord, still didn't show any AC power on.

I'm guessing it's an incompatibility issue, since somehow it doesn't happen on XP.

I'm hoping a simple "sudo gedit xxxx" can do the magic and correct it?
Reply With Quote
  (#4) Old
gunn gunn is offline
Member
 
Posts: 33
Join Date: Nov 2008
Post Re: AC power disables when battery hits 100% charge. - 11-02-2008, 01:25 PM

Something really sad just happened. I shutdown the computer and the battery recharging indicator was OFF! Even when power down, it was not getting any power from AC.

Damn, I already contacted DELL's tech support. I will just wait till Monday to get a response.

Hardware defect! I'm now 100% sure!
Reply With Quote
  (#5) Old
gunn gunn is offline
Member
 
Posts: 33
Join Date: Nov 2008
Lightbulb Re: AC power disables when battery hits 100% charge. - 11-02-2008, 03:37 PM

I think I might have found the solution.

You can find on the thread "battery not charging" a possible, quite promising, solution. I don't know how it works. But just wait and see.

All credits to dougma. 8-)
Reply With Quote
  (#6) Old
DjFIL DjFIL is offline
Junior Member
 
Posts: 7
Join Date: Oct 2008
Default Re: AC power disables when battery hits 100% charge. - 11-05-2008, 01:20 AM

This issue was occurring after I reinstalled Windows XP too... so I'm certain it's hardware flaw. Dell is sending box for me right now, they'll do the whole replacement thing. Hopefully a quick procedure.
Reply With Quote
  (#7) Old
gunn gunn is offline
Member
 
Posts: 33
Join Date: Nov 2008
Default Re: AC power disables when battery hits 100% charge. - 11-08-2008, 03:18 PM

Quote:
Originally Posted by DjFIL
This issue was occurring after I reinstalled Windows XP too... so I'm certain it's hardware flaw. Dell is sending box for me right now, they'll do the whole replacement thing. Hopefully a quick procedure.
I installed windows xp as a dual boot and this **** happened again. What really annoyed me is that this kept on happening when I was using Mini at home, but not when at office (I usually spend over 10 hours at work.)

As months ago I did have a power problem with my other Dell desktop at home, I still suspect that it's probably because of the unstable power in my house. So, I'll just wait till it happens in my office. Sigh...

Anyway, can you please tell me if Dell has any explanation for yours after the replacing? Thx. :P
Reply With Quote
  (#8) Old
DjFIL DjFIL is offline
Junior Member
 
Posts: 7
Join Date: Oct 2008
Default Re: AC power disables when battery hits 100% charge. - 11-08-2008, 07:29 PM

Yeah I'll post any details that I can get from Dell regarding the issue... it might take a little while. it took 5 business days to get the box to me, but it's partially because our local currior that dell uses has been backed-up for a while now and all deliverys are delayed a day or two more *sigh*.
Reply With Quote
  (#9) Old
DjFIL DjFIL is offline
Junior Member
 
Posts: 7
Join Date: Oct 2008
Default Re: AC power disables when battery hits 100% charge. - 11-19-2008, 12:42 AM

I wish I could tell you what the problem was... Dell never ended up fixing it and sent me back the same defective unit. The tech notes said they replaced the battery and ac power adapter, but did nothing at all with the OS or the Motherboard/BIOS... they are f'n idiots. So I called back Dell... and even though I'm past the 30 day grace period... I am getting a full refund on my Dell Mini 9 and saying good-bye. I'll be moving on to a Samsung NC10, either imported or once Samsung brings them to Canada in Q1 2009.
Reply With Quote
  (#10) Old
medicThree medicThree is offline
Senior Member
 
Posts: 403
Join Date: Oct 2008
Location: Middle Earth
Default Re: AC power disables when battery hits 100% charge. - 11-19-2008, 01:02 AM

You should try the A02 bios upgrade available from the dell site. THe only change to it was power management, so maybe it could fix it.

It is super easy. Just open, run, be done. If it bricks it, just send it in as planned and deny, deny, deny.
Reply With Quote
Reply

Tags
battery, charging, mini 9

« Bluetooth module not recognised after clean XP reinstall | New ssd windows 7 install help »
Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off


Copyright © 2008-2016 MyDellMini.com.