Dell Mini 9 Hardware Issues / Problems Inform everyone on any issues or problems with your Dell Mini 9 hardware.

Thread Tools Display Modes
  (#1) Old
jerry jerry is offline
Junior Member
Posts: 1
Join Date: Mar 2009
Default Mice stopped working (but work on other machines) - 03-26-2009, 06:05 AM

I have a one week old mini 9 that came with ubuntu. I installed the A04 bios. It seemed to be working fine for a day or two with a small optical usb targus mouse. I put XP SP3 on it, and still, it worked fine for a day or two with this optical usb mouse. I installed all the Dell drivers and everything was working find.

And then, with some rift in the space time continuum, I now see the following behavior. A mouse, attached for the first time to a USB port, will work just fine for about 3 seconds and at the same time I can see Windows going through the stages of recognizing the mouse. The pointer tracks. The scroll wheel scrolls. Clicks click. At just about the time that Windows told me it has installed the mouse fine, the mouse stops working. The touchpad seems to work just fine.

The LED remains lit. But clicks don't click, the wheel doesn't scroll, and moving the mouse around does nothing to the pointer.

If I put the mouse into another port that it has never been attached to before, the same thing happens.

If I put a different mouse (and a different kind of mouse) into these ports, the same things happen.
If I attach these mice to my other machines, they work fine. This is true for my targus optical mouse, my logitech optical wheel mouse, and my microsoft optical wheel mouse.

If I go into device manager and delete all the usb hubs and let the system reboot and refind all those devices, I can go through the entire cycle again. Windows Update tells me there are no hardware updates related to the machine.

Googling, I found one other person who seemed to have this issue, but there was no resolution to that problem.

Dell suggests I put ubuntu back on the machine and see what happens. If the mice still don't work, they will replace the machine. Which is fine, but I wonder if anyone has experienced anything similar and can give me some hints.

Thank you.
Reply With Quote

« So I'm still having wireless issues. | bluetooth vs. wifi »
Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Copyright © 2008-2016