Dell Mini 9 Hardware Issues / Problems Inform everyone on any issues or problems with your Dell Mini 9 hardware.

Thread Tools Display Modes
  (#1) Old
btradio btradio is offline
Junior Member
Posts: 2
Join Date: Mar 2009
Default Wi-Fi not recognized (UPDATE) - 03-14-2009, 02:44 AM

Hey guys-

first off, site is great and everyone is very informative. Hoping you can help me with this problem.

Just got a refurb XP mini9. (1gb/8gb)

I am having trouble with the WiFi connection. It's almost like the comp doesn't see it at all. As if there was no wireless installed in the box. However, it does come on intermittently (and works fine when it is on.) However, it is missing way more than it is visible. To the point that when I view network connections, I don't even see the wifi option, just the LAN.

Would you guess that the wifi card is just not connected properly? How big of a deal is it to check that?

Thanks for the help!

I pulled the back off and reseated the WLAN card. Everything was clean and connected properly. I rebooted the computer, and it immediately connected to my network. However, 20 seconds later (literally) it was gone. the WLAN no longer shows in the network places list and disappears out of the systray. Starting to think that a bad card is the only answer.
Reply With Quote
  (#2) Old
somms somms is offline
Super Moderator
somms's Avatar
Posts: 883
Join Date: Oct 2008
Location: FAA
Default Re: Wi-Fi not recognized (UPDATE) - 03-14-2009, 12:47 PM


You may want to reinstall the Broadcom wireless driver...latest v5.10.79.5 linked above!

Reply With Quote
  (#3) Old
btradio btradio is offline
Junior Member
Posts: 2
Join Date: Mar 2009
Default Re: Wi-Fi not recognized (UPDATE) - 03-14-2009, 03:38 PM

I did do that. However, it took multiple tries to do it because the first couple of times I ran the update it stopped because it didn't find any compatible hardware.

For whatever reason the system is not seeing the wifi card most of the time. As far as the system is concerned there is no card installed at all.
Reply With Quote
  (#4) Old
STiMULi STiMULi is offline
Senior Member
Posts: 251
Join Date: Feb 2009
Location: Tucson Arizona
Default Re: Wi-Fi not recognized (UPDATE) - 03-15-2009, 04:33 AM

Even though this persons issue has been resolved it seems that my self and other are having the same issue as you are and this may be a good thread to keep the info and updates.

You are having the same problem I listed in this thread...


l will update the latest on my issue in that thread

Mini 9 MacBook Aspen White
Runcore 64GB | 2GB RAM | ATP 16GB C6 SDHC | 1.3 Webcam | Bluetooth | OSX 10.5.6 | Fusion w/Windows XP | CrossOver | DellEFI 1.2A5 | BIOS A04 | 77Whr Battery

Will install OSX for Food
Reply With Quote
  (#5) Old
Mastermind278 Mastermind278 is offline
Junior Member
Posts: 1
Join Date: Mar 2009
Default Re: Wi-Fi not recognized (UPDATE) - 03-16-2009, 03:12 PM

I also have the same exact problem with my refurbished unit. As soon as I got it home it had that issue. I called Dell and they said it wasn't hardware and it was a software issue. I explained to them that I had reinstalled the drivers and was still having this issue, and that the only way to get the wireless to work was via a "repair" which in essence just disabled the card and reenabled. And sometimes it would disappear from the system and only after various reboots it would finally show up. Then they suggested I PAY for their "premium support" to figure it out. After another call I spoke to another CSR who agreed to send a new Wireless card. This temporarily fixed the problem. Now it has once again stopped working. But it now doesn't even show up on device manager or network connections. It will only show up every once in a while after I keep removing the card and putting it back and rebooting till it shows up. But only works for 20 seconds and then disappears. I once again called DELL with the problem and they once again suggest it is a software issue. They wanted me to reinstall windows, but after I explained I did not have an external DVD drive they said they would send a new HD with a fresh XP install... But I still believe it is not a hardware issue.

I would love to hear updates on this problem from other people.
Reply With Quote
  (#6) Old
hddn_agnda hddn_agnda is offline
Junior Member
Posts: 8
Join Date: Mar 2009
Default Re: Wi-Fi not recognized (UPDATE) - 03-17-2009, 06:34 PM

I work for a University that has a premier account with Dell. We had a faculty member order a brand new Mini9 and was having this exact same issue.

Long story short, I explained that I had tested the card in both the XP Home install that shipped with the device and then again with a separate XP Pro install. They shipped out a new Wifi card that was here next day and the issue was resolved.

It was a while back and I forget what the new card they shipped was, but the bad one (still in my desk as they did not require it be shipped back) was a Broadcom BCM94312MCG.

I should note that they originally requested I ship the device back to them for the replacement, but as we do a lot of business with them (and have gold support, 3-yr warranty, complete care standard on all our machines) and that I am always the person that troubleshoots hardware/software issues and requests replacement parts, the support person was allowed to ship me the part with the warning that if I damaged anything it would not be covered.

Unrelated Side Note: I had been eying the Mini 9 for quite some time and after getting to setup (read: play with) the faculty member's Mini9 for them I ordered one for myself during the recent sale. I got it last week and all my upgrades (save for the 32gb Runcore ssd) are finally in.
Reply With Quote
  (#7) Old
Elcuolo Elcuolo is offline
Junior Member
Posts: 7
Join Date: Mar 2009
Location: UK
Default Re: Wi-Fi not recognized (UPDATE) - 03-18-2009, 12:19 PM

There have in the past been problems with the connectors (mini pci) to the motherboards - HP have had to recall a load of mother boards that were exhibiting a problem caused by excessive heat from the components - this was supposedly fixed by a change in the revision of the Bios.

Whilst i'm not syaing that this IS the problem with a Net Book that only has passive cooling dependant upon how hot the area that it is used in it might affect it.

Just my input anyway.


Reply With Quote
  (#8) Old
tpc1249 tpc1249 is offline
Junior Member
Posts: 1
Join Date: Mar 2009
Default Re: Wi-Fi not recognized (UPDATE) - 03-22-2009, 10:00 AM

I am new to this thread and am having the same or a similar problem. My Mini 9 has XP and was purchased new.

Upon booting, WIFI works fine, then simply disappears. The wireless icon at the bottom of the window disappears and the Broadcom wireless adapter no longer shows up in the device manager. Initially, it appeared that "scan for changes" refound the adapter, but that no longer works for me. I tried the Dell chat support but "Irene" told me she couldn't resolve my issue and gave me an 800 number connected to canned answers to simple connection problems. I guess I will install new drivers next. I am not sure how to check the card itself. Suggestions would be appreciated!
Reply With Quote
  (#9) Old
FishCake FishCake is offline
Junior Member
Posts: 1
Join Date: Jul 2009
Default Broadcom Wireless MISSING HARDWARE - 07-10-2009, 06:36 PM

hello. my dell mini 9, which has a Broadcom Wireless card is not working. Well once in a blue moon it decides to work, maybe for less than a minute, then poof it disappears. like others in this forum, the device is no longer listed in the Windows Device Manager. I tried installing the Broadcom drivers, but because the wireless card disappears after a short use, i can not install it.

Do anyone have a fix for this?
Reply With Quote
  (#10) Old
scoobysnacks scoobysnacks is offline
Junior Member
Posts: 11
Join Date: Jun 2009
Default 07-11-2009, 03:11 PM

It's a bad card - I had the same behaviour under Mac OS for weeks until I replaced the wifi card. No more problems since then.

Btw, I replaced it with a BCM93411 as this was cheap and easy to find. Works perfectly, so recommended.

Reply With Quote

« grrrr need to excercise my warranty. | Installing BT drivers »
Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Copyright © 2008-2016