Dell Mini 9 Hardware Issues / Problems Inform everyone on any issues or problems with your Dell Mini 9 hardware.

Thread Tools Display Modes
  (#1) Old
asterix asterix is offline
Junior Member
Posts: 2
Join Date: Feb 2012
Location: UK
Default Mini 9 Power problems. - 02-05-2012, 05:35 PM

Hi Everybody, 1st time poster long time reader. Long description please bare with.

OK need some advice with this Mini 9 (Inspiron 910), got hold of this netbook for my nephew just before Christmas, it came with dead HDD, while I was waiting for new one to arrive, thought I may as well charge the battery so everything is ready just to give him it back, then found the battery won't hold a charge, ordered a new one, got new HDD 16gb and battery installed them both, went to format it with the AC adapter connected (as your supposed to do) and 5 minutes in an the adapter popped, managed to borrow another adapter from a friend, managed to format and install XP with the battery disconnected, installed everything Dell advised and Netbook worked great from AC power.

If I disconnect the AC adapter and plug the battery if boots perfect and works great, so thought it must of been a glitch so plugged adapter back in and it popped again charger overheated, sent battery back got a refund, ordered 2 new adapters (1 to replace friends) and a new battery 4400mah one, they arrived, battery was fully charged so plugged it in, then got message saying something about battery needing to be Initialized or something like that, anyway was told that a Bios update should solve this, so plugged the new AC adapter in and within 5 minutes that popped, so I wasn't able to update Bios, borrowed adapter again took battery out but now the Netbook won't power up, but it will from the battery, but the battery doesn't have enough power to update Bios.

Also is there an adapter available to charge the battery out of the Netbook.

Sorry it's a long read, any advice would be gratefully received.

Last edited by asterix; 02-05-2012 at 05:40 PM.
Reply With Quote

« Bios does not see SSD OCZ MSAT | Tell me I didn't hose my ssd »
Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Copyright © 2008-2016