Dell Mini 9 Hardware Issues / Problems Inform everyone on any issues or problems with your Dell Mini 9 hardware.

Thread Tools Display Modes
  (#1) Old
Schwartz Schwartz is offline
Junior Member
Posts: 1
Join Date: Jan 2010
Default Wifi issue, please help. =\ - 01-22-2010, 02:50 PM

So to make a long, stupid story short...

I wanted to replace my wifi card as the one that came with my Mini9 would stop working after a few minutes. In the process of trying to remove the old card, I stripped a screw, pain and tears were involved, and I finally got it removed without damage to the motherboard, but the palmrest/topcase managed to get half of a magazine superglued to it. (Yes, seriously.)

So, got a refurbed palmrest, and everything works fine in that aspect. Ordered a refurb Wifi card, hook up the antenna (black wire goes towards RAM, correct?) and the card shows up in device manager, but I can never find any wireless networks. I got frustrated last night and stopped messing with it after a few reboots and reseats, but I'm going to troubleshoot it as a software issue first and reinstall the driver, but I don't think that's the issue. What can I check antenna wise to make sure that it wasn't damaged at some point? Best case scenario is a jacked up card I suppose, and hopefully I can get an exchange.

Running Win7, BTW.
Reply With Quote
  (#2) Old
holmes4 holmes4 is offline
holmes4's Avatar
Posts: 6,157
Join Date: Nov 2008
Location: New Hampshire
Default 01-22-2010, 03:18 PM

There should be two antenna wires. The order of connection does not matter. You might have damaged the antenna connector - they are fragile.

Mini 9|2GB RAM|64GB RunCore|Intel 5300|Windows 10
Reply With Quote

« Wi-fi problem | Yet another battery issue »
Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Copyright © 2008-2016