Dell Mini 9 Hardware Issues / Problems Inform everyone on any issues or problems with your Dell Mini 9 hardware.

Thread Tools Display Modes
  (#1) Old
sn34ks sn34ks is offline
Junior Member
Posts: 11
Join Date: Oct 2009
Post Dell Mini 9 - Inspiron 910 - Snow Leopard Wi-Fi Problem Resolved - 10-04-2009, 07:10 PM

I have been pulling my hair out trying to figure out why my Wireless was not working with Snow Leopard. It was extremely glitchy; ie I'd have it for a minute, then it would be gone and SL would act as if there was no wireless card installed.

I did not have much luck finding anyone with a similar issue and spent MANY hours trying to resolve it. Hopefully this will help someone else with a similar issue.

The BIOS was at A04 and after I updated it to A05, the glitchy wireless issue was gone and everything worked perfectly. I don't know if this was dumb luck (as it seems) but regardless it works perfectly now.

I followed the steps here to flash my BIOS to A05: HOWTO: Upgrade your bios with OS X which worked flawlessly (thanks AppleGuru!)


The above info did not fix my issue; was only an illusion. About 45 minutes after this post, it started doing the same thing again. I tried everything I could possibly find online to get this card to work. I have just about worn out the PCIE slot be removing and installing the card which seemed the only way to get it too respond.

Alas... The issue was the card itself. I installed a new Dell 1505 card this morning and it has been running ever since.
Reply With Quote

« Can't enter BIOS | Battery life after SSD and OS X upgrade halved? »
Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Copyright © 2008-2016