Dell Mini 9 Discussion Discussion on the Dell Inspiron Mini 9.

Thread Tools Display Modes
  (#1) Old
medesmond medesmond is offline
Junior Member
Posts: 2
Join Date: Dec 2010
Arrow Dell mini 9 - BIOS Not POSTing, nothing on screen - 01-03-2011, 08:29 PM

One day all of a sudden the laptop switched off. The screen blanked out. After that the Bios never POST ed. No beeps and nothing on the screen. Powers up for a few seconds and then powers off. Disassembled the whole computer checked all connections and found nothing wrong. Removed SSD, RAM, Wireless and yet no beeps. Removed each one individually no beeps. LCD connections are OK too. Can anyone throw some light on what the problem might be and help me solve the problem? I am zeroing in on a board level failure. Thanks for your help.
Dell inspiron 910 (mini 9)
Reply With Quote
  (#2) Old
rrfranczak3 rrfranczak3 is offline
Super Moderator
rrfranczak3's Avatar
Posts: 2,902
Join Date: Aug 2009
Location: Upstate New York, U.S of A.
Send a message via AIM to rrfranczak3 Send a message via MSN to rrfranczak3 Send a message via Yahoo to rrfranczak3
Default 01-03-2011, 09:24 PM

can you get into the BIOS at all?, think its '0' at boot

also might be that the AC adapter failed and the battery is completely dead now?

Dell Mini 10 (Obsidian Black 1010), 2gb RAM, 1.66ghz 533mhz FSB (Z530) processor, A10 BIOS, 1 Terabyte (1000 GB) WD Scorpio Blue Hard Drive (5400rpm), Intel GMA 500 Integrated Graphics, TV Tuner, Bluetooth 2.1 module with EDR, 1.3mp Camera, 1366x768 HD Screen, Wireless 1510 b/g/n mini card, 6 cell (56WHr) Battery, 4gb SDHC, 64gb Flashdrive, Targus Netbook Chillpad, Targus Sport Case, Windows 7 Ultimate SP1 (500gb)/Windows 8.1 (500gb) (Dual Boot)

iPad 4 (64gb) w/Retina,Targus Versavu Case
Reply With Quote
  (#3) Old
medesmond medesmond is offline
Junior Member
Posts: 2
Join Date: Dec 2010
Default Re: - 01-03-2011, 09:32 PM

Thanks for the reply,

I can't get in the BIOS. No activity at all. I did the voltage checks and resistance checks across the motherboard and all seem to be normal. The battery is good (last time I checked it, it showed 6 hrs remaining and fully charged). I checked the power adapter and it is good too (18.8 Volts out and no shorting). Any further insights into what might be the problem? Thanks again
Reply With Quote
  (#4) Old
grungysquash grungysquash is offline
Senior Member
Posts: 229
Join Date: Jan 2009
Default 01-04-2011, 05:58 AM

Seems like you have done all of the normal steps, for any computer to post a bios it needs working ram and CPU. If the SSD had failed you would still get to the bios so based on this I believe your data is safe.

The logical things to do like reseating the ram have been done, so one quick thing to do is swap out a spare DDR2 ram chip from a working laptop, this will eliminate the ram as the cause. The only other suggestion I have is to unplug the bios battery to reset it. If non of these work then it becomes tricky!!!! - As the CPU is soldered onto the mobo there is no option on swapping it out. And as you have already checked rather thoroughly the power supply then this can be eliminated, there is little else that can be done. The only recommendation I can make would be to look at ebay for a unit with a smashed screen. The mini 9 is at EOF and you won't get any spare parts from dell so your left to ebay or partspeople.
Reply With Quote
  (#5) Old
fitnessman fitnessman is offline
Junior Member
Posts: 11
Join Date: Jan 2011
Default 01-11-2011, 02:05 PM

help, i have the same issue, was perfroming a bios update from dells site and now i get a black screen with beep, blank, beep beep, recurring every second. is it dead?
Reply With Quote

bios not posting, blank screen, no beeps

« Coin Battery in Dell Mini 9? | Master Bios Password »
Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Copyright © 2008-2016