Dell Mini 10v Forum for all discussions and support on the Dell Mini 1011, also known as the Mini 10v. If your question is regarding Mac OS X, please use the Mini 10v Mac OS X forum.

Thread Tools Display Modes
  (#1) Old
BerSerK BerSerK is offline
Junior Member
Posts: 5
Join Date: May 2011
Location: London, UK
Default i messed my triple boot up - 05-08-2011, 09:28 PM

hi guys,

i read today through many topics to get my triple boot installed. just purchased an 1011 and wanted to get everything on it. macos, ubuntu and win7.

the best help for me were these links:
Triple boot with Chameleon bootloader – Windows 7 | OS X 10.6 | Ubuntu 10.10 OSX86SV

i started win7 and created the partitions, restarted and booted from macos usb (Dalton63841's SnowyWindOSX Final (GUID/GPT). installed and when it wanted to reboot while install i changed to my win7 stick.
installing win7 as usual, shut down the machine and booted up my ubuntu 11.04 stick.
install of ubuntu was fine as well.

the next descriped step was to change the grub as it's not working properly otherwise.
instead of changing i got an error. the error was something like "it's not a good idea. blacklist is not good" or something like that (i googled at this time but couldn't find any clear description how to force this step...).

so i figured, who cares, i can do it later.
so i went back and finished the install of macOS (incl netbook installer for chameleon loader).

as soon as i went in my freshly installed macos i started the updateEFI, log out, log in.
start of combo update, while it was done (and the window "restart" still open) i opened update gpt, done in this one and restart in the combo update window.

restart of the computer and boot in mac: "please shut down your computer. you do this with pressing the power button until the amchine turns off" or something like this (in 4 languages).
the same problem i had the whole day with trying different installs. i believe it's becasue of the combo update...

boot was as followed:
macOS: turn off error
ubuntu: missing/wrong grub
windows: working fine

and at this time i was DAMN STUPID. i booted into windows and wanted to create my data partition (for creating a norton ghost image before messing with my nearly wokring partitons). while creating this one my windows assigned letters to all partitions and lost the own "c" letter.

so i tried again the netbookloaeder but it didn't find a partiton for it. so i went back to win7 install and changed the osx parition to active. tried "convert gpt" as well but it didn't let me.

now i can't boot anything. just reboots everytime. instead of showing any bootloader it goes back to the startup.

my partitons are as followed (or should be...):
1. EFI - 200mb
2. primary - 25GB (macos)
3. primary - 30gb (win7)
4. swap - 500mb (swap)
5. ext4 - 25gb (ubuntu 11.04)
6. unallocated (yes, stupid me tried to make an extended out of it and screwed everything up...)

could i have avoided this problem would i had created a FAT drive with ubuntu while install?

i will do all the steps again now to have a proper clean setup (where i don't do anything until my ghost image is safe!!!)

but may be you have some ideas why the update (hope it's just the update) makes problems and how to change the grub partition?

btw: i'm newbie with MacOS, good experienced with windows and a standard x-windows ubuntu user


i read for macos on the dell i would need bios version A04, on mine is A06... could this be the problem for both problems? just on the links i used (and damn, they are pretty easy to follow) it's not mentioned at all...

Last edited by BerSerK; 05-08-2011 at 10:07 PM.
Reply With Quote
  (#2) Old
BerSerK BerSerK is offline
Junior Member
Posts: 5
Join Date: May 2011
Location: London, UK
Default 05-14-2011, 11:32 AM

i tried it again. didn't take long but still... i'm tired of trying

so i did the exact same steps again. didn't install the update and it's working better. still didn't recognise my display perfectly (just 800x600 resolution).

win7 was working and ubuntu still didn't let me install grub.

so today i wanted to try something else. plain mac os install. and while install already the shut down error.

so i downgraded my bios. still the same. so partioned my hdd again and atm i'm installing osx.
install done, started updateefi, logged out.
logging in, installing comboupdate.
there i am now. will edit as soon update is done, and updategpt is done as well.
let's see if it works. if so i'll proceed with win7 install. try this out and if both are working i'll follow up with ubuntu install.

just not sure if i would have to run netbookinstaller from my boot flash as well if i just run macos x or would it mess up with installing win7 and ubuntu afterwards?
i mean, i should be able to run the netbookinstaller everytime again, am i right?

done... not wokring. still the damn restart message. just while booting up.
so next test will be plain again.

haha, stupid me.
why do i choose GUID if i still have to use the mbr fix???
the blody damn thing is as well that i can't format the whole disk as i get just "device busy" message... so i can create the partitions with win7 install flash and change it to gpt. but i can't do it with the osx flash.
i also downgraded my bios to a04 (which shouldn't make any difference if i believe all of the threads and uncountable comments...).
also updating after using the "MBR.pkg" and "UpdateExtra v1.0" files works. just no usb will be recignised for whatever reason. and netbookinstaller afterwards just gives the panic_kernel again.

so what am i going to do next?
my wifi is recognised while install process but not afterwards. just the ethernet.
still trying with different packages, but have to put them on harddisk before as i'm afraid of losing usb function again...

Dell Mini 10v - 1011 - (triple) boot

Last edited by BerSerK; 05-18-2011 at 09:05 PM.
Reply With Quote

triple boot loader 1011

« 1010/1011 LCD Swap Results. In short, no go. | Time Machine Restore? »
Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Copyright © 2008-2016