Dell Mini 10v Forum for all discussions and support on the Dell Mini 1011, also known as the Mini 10v. If your question is regarding Mac OS X, please use the Mini 10v Mac OS X forum.

Thread Tools Display Modes
  (#1) Old
tribbs tribbs is offline
Junior Member
Posts: 2
Join Date: Jun 2010
Default Battery wouldn't charge; happy ending - 06-24-2010, 07:57 PM

So a couple of months ago the 3-cell battery in my 10v stops charging, and rebooting it gave me a 'The battery cannot be identified.' message. Ugh. I finally got around to calling Dell yesterday afternoon and they agreed to replace the battery pack under warranty.

They said it would take two to three business days for the replacement to arrive, but imagine my surprise when my wife called me this morning and told me it was here. I went home for lunch and was further surprised when I opened the box to find that they had sent a 6-cell pack as a replacement.

10v | Black | A05 | 10.6.7 | 1GB/160GB | 6-cell

Reply With Quote
  (#2) Old
vahnx vahnx is offline
Posts: 84
Join Date: Sep 2009
Default 06-28-2010, 07:51 AM

Nice score! And let me be the first to say welcome to the Mydellmini community!

Dell Mini 10v | Bios A06 | 2GB RAM | 40GB SSD w/ OS X 10.6.7 | 6-Cell Battery | NBI 0.8.5pre
Reply With Quote

10v, battery, warranty

« New SSD is very slow | Do I need to upgrade to 2GB RAM to run win 7 WELL? »
Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Copyright © 2008-2016