Dell Mini 10v Forum for all discussions and support on the Dell Mini 1011, also known as the Mini 10v. If your question is regarding Mac OS X, please use the Mini 10v Mac OS X forum.

Thread Tools Display Modes
  (#1) Old
jaykoby7 jaykoby7 is offline
Junior Member
Posts: 6
Join Date: Nov 2009
Default My dell mini 10v shocked me (literally) - 12-09-2009, 11:58 PM

So I just got my dell mini 10v today. its really nice and everything, but this has happened twice, When I put my had underneath it to lift it off my lap, it shocked me. It has happened twice so far. Ive been using it for about an hour. Any Ideas Why this is happening? I guess I could compare the shock feeling to when you would get shocked with a novelty gag shock pen. For those you know what that is. Like i said, it doesnt happen every time. So far only twice. Thanks.

And its not static, I can tell the difference
Reply With Quote
  (#2) Old
holmes4 holmes4 is offline
holmes4's Avatar
Posts: 6,157
Join Date: Nov 2008
Location: New Hampshire
Default 12-10-2009, 12:25 AM

Some months ago someone reported a similar occurrence with a Mini 9. I would consider this a defect and would call Dell. It could be dangerous.

Does it happen only when plugged in?

Mini 9|2GB RAM|64GB RunCore|Intel 5300|Windows 10
Reply With Quote
  (#3) Old
Bear Hunter Bear Hunter is offline
Senior Member
Bear Hunter's Avatar
Posts: 423
Join Date: Sep 2009
Default 12-10-2009, 01:09 AM

I've found that you have to grab it a certain way underneath with the LCD up. It's not really a shock, more like a very very tiny bit of current. Might be sweaty palms and the VGA port on the right side...I don't know.

Dell Mini 10v Mac OSX 10.6.2 1 GB RAM 160GB HDD BIOS A05 Blue Tooth 1510 WLAN 802.11g /n

NBI 8.2 -> NBI 8.3RC2 -> NBI 8.3RC3 -> NBI 8.3RC5 -> NBI 8.3 alpha

USB Legacy Disabled | USB Wake Enabled | BT Enabled |
Reply With Quote
  (#4) Old
jaykoby7 jaykoby7 is offline
Junior Member
Posts: 6
Join Date: Nov 2009
Default 12-10-2009, 05:16 AM

I was just using it for couple of hours to test everything out, now i have to wait until christmas as it is my present. Im going to tell my parents about what you said, they may let me use it to see if it occurs again. Like I said, it is different than static electricity. Ill try to investigate it more. If anyone else knows more about it, let me know. thanks

---------- Post added at 11:16 PM ---------- Previous post was at 09:45 PM ----------

Update: I contacted dell livechat support. And I told him what happened. Then a couple minutes went by and told me he talked to his supervisor and that they were going to ship me a new unit. Its going to take max 3-4 weeks. but they said they would expedite it. They were really nice. The delay doesnt really matter though, because its not like I was getting it before christmas anyway. It seemed like they took this issue very seriously. I was hoping they wouldnt make me return the shocking one though lol. but they are when i get the new one.
Reply With Quote

« Mini 10v + Snow Leopard Install Disc + 1TB exHD = ? | switching bluetooth off? »
Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Copyright © 2008-2016