Dell Mini 1018 Forum for discussion on the refreshed Dell Mini 1018, released Q3 2010.

Thread Tools Display Modes
  (#1) Old
kriminemil kriminemil is offline
Junior Member
Posts: 2
Join Date: Dec 2011
Question BIOS Update Mini 1018 - 12-30-2011, 06:50 PM

Hi Partypeople outhere =)

I am have some problems with my inspiron mini 10 (1810),
since running ubuntu 10.10.

The webcam and the wifi-card doesn't work anymore,
only while the installation process.
I reported the issue on ubuntuuser's board and the people
suggested to update the BIOS.

My bios system is now running on A2:
Product Name:           Inspiron 1018
Vendor:                 Dell Inc.
BIOS Version:           A02
System ID:              0x048E
But i dont find the right driver here:]Index of /repo/firmware/bios-hdrs

is there a compatible one?

At Dell's support, there is no newer version than mine...

Is there a more uptodate version?
Where can I find that?

Best regards,

Reply With Quote
  (#2) Old
reflex reflex is offline
reflex's Avatar
Posts: 1,997
Join Date: Apr 2009
Default 12-31-2011, 02:17 AM

Newest 1018 BIOS looks to be A02.

As for the wifi card, if I recall correctly, the 1018 has a new Realtek wifi card, and older kernels might not support it. Maybe try a newer version of Ubuntu (with a newer kernel and drivers), even just on a flash drive.

Search the forums, somebody else had trouble with 1018 wifi in Linux a while back.

I dunno about the webcam.

Mini 9 | Intel 5100 Wifi | Ubuntu 10.04 Netbook
Mini 1012 | SSD | Intel 6200 Wifi | Ubuntu 11.10 64bit
Reply With Quote
  (#3) Old
rrfranczak3 rrfranczak3 is offline
Super Moderator
rrfranczak3's Avatar
Posts: 2,902
Join Date: Aug 2009
Location: Upstate New York, U.S of A.
Send a message via AIM to rrfranczak3 Send a message via MSN to rrfranczak3 Send a message via Yahoo to rrfranczak3
Default 12-31-2011, 06:27 AM

dont be in such a hurry to mess with the BIOS unless you want a nice expensive paperweight or a happens ALL THE TIME......

Dell Mini 10 (Obsidian Black 1010), 2gb RAM, 1.66ghz 533mhz FSB (Z530) processor, A10 BIOS, 1 Terabyte (1000 GB) WD Scorpio Blue Hard Drive (5400rpm), Intel GMA 500 Integrated Graphics, TV Tuner, Bluetooth 2.1 module with EDR, 1.3mp Camera, 1366x768 HD Screen, Wireless 1510 b/g/n mini card, 6 cell (56WHr) Battery, 4gb SDHC, 64gb Flashdrive, Targus Netbook Chillpad, Targus Sport Case, Windows 7 Ultimate SP1 (500gb)/Windows 8.1 (500gb) (Dual Boot)

iPad 4 (64gb) w/Retina,Targus Versavu Case
Reply With Quote
  (#4) Old
kriminemil kriminemil is offline
Junior Member
Posts: 2
Join Date: Dec 2011
Smile 01-02-2012, 05:56 PM

Thx, Bros! I found my solution: just resetting the BIOS to the default values. I didn't messed them up, but maybe the mini needs it sometimes... Some other guys did have the same problem since ubuntu 10.10 ... so.. Have a nice day =)
Reply With Quote

« The End? Dell Quietly Removes Dell Mini | Fail: Upgrade to 1366x768 and 8 beeps error. »
Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Copyright © 2008-2016